Page 1 of 1

Running on Linux

PostPosted: Sun Jan 16, 2005 2:31 pm
by Derek
I know a number of users run Wave Corrector under WINE on Linux. It might be useful to share your experiences here.

For myself, the latest iteration of WINE (20050111) appears not to run Wave Corrector, at least not on my system. It gets stuck opening the program and it looks as though it is in an endless loop refreshing the screen. :(

The previous version (20041201) does not have this problem and runs Wave Corrector more or less perfectly.

PostPosted: Tue Feb 22, 2005 9:39 am
by Derek
This is just to report that the latest build of WINE (20050211) fixes the screen refresh problem :)

So all you LINUX users can happily update to this latest version.

Using on Linux

PostPosted: Sat Apr 16, 2005 2:28 am
by Shane Knudsen

Glad to see this forum topic! I originally purchased wave corrector to use on my windows computer, but once I installed Linux, I almost never use my windows partition. I hava a dual-boot system, and I just run Wave Corrector right off of my NTFS partition using WINE. The newest version (20050310) even allows me to use the delayed start feature properly. The 20041201 version didn't allow me to do that. The program otherwise worked just fine. Now I don' t have to bother with booting into windows to record my saturday morning radio shows that I always miss.

Have fun

PostPosted: Sat May 07, 2005 12:34 pm
by Shane Knudsen
Just installed a new hard drive and in my computer, and I'm just running linux on it. When I tried to install Wave Corrector, I get an error message:

Access Violation at 77EC43DD. Write of address 0053004D.

Tried installing as both user and root.

PostPosted: Sat May 07, 2005 3:54 pm
by Derek
Thanks for pointing this out. I must admit I have never used the installer to install Wave Corrector on a Linux PC. Instead, I have simply manually copied the Wavecor.exe file to the Linux machine.

I've just tried using the installer program and I get the same access violation that you report.

Doing a little Googling, I've discovered that the problem arises because the installer program in incompatible with Wine's built-in riched20 DLL.

The solution is to place a copy of the Windows DLL in the Windows/system folder on the Linux machine and to run the installer with the following command line

WINEDLLOVERRIDES="riched20=n" wine wcor_31.exe

There is some more information on this at: ... opic=14530

PostPosted: Mon May 09, 2005 3:14 am
by Shane Knudsen
Wow, that totally worked. I downloaded the .dll file from here:

Thanks for the tip.

by the way, the full path to put it into is:


Version 20050310 of wine makes it more or less work, but some of the buttons look funny. They still work, which is the important part. version 20050419 just came out, so I'll try that tomorrow. The delayed start input is broken again, too. I'm sure WINE will get around to fixing it, so I'll just be patient. I'm used to it using Linux!

Thanks for the post, Derek, that was really helpful.


PostPosted: Mon May 09, 2005 3:28 am
by Shane Knudsen
Version 20050419 does indeed more or less fix the delayed start option trouble. There are no handy up and down arrows, but you can just use your keyboard arrow keys to change things. After rebooting the computer, the buttons and other graphics are fixed

By the way, I run Fedora Core 3 on my box, in case anyone is curious.