Click at start of some tracks after burning with no pause

Please post your support queries here.

Moderator: Derek

Click at start of some tracks after burning with no pause

Postby Steve » Tue May 01, 2007 9:53 am

Hi

I've been using wave corrector for some years now but have only just joined the forum.

I edit a lot of live recordings and obviously don't want a pause between each track, and I've found that gapless track boundaries works best. However, everything seems fine until a CD has been burned (I use Nero version 7.8.5.0 with the "no pause" between tracks feature). The CD plays fine and the transition from one track to another is seamless when played continuously, but if I select specific tracks there is an audible "click" with some of them at the start of the track, which I think might be the a split second of the end of the previous track. It only happens with some tracks on a burned CD, and if it's there it's there permanently. Sometimes if I'm lucky a CD will be completely OK. I don't know whether this is down to Wave Corrector, Nero or my CD writer. Does anyone else get this annoying problem? Is there anything I should be doing in Wave Corrector to prevent it? Thanks.

Steve
Steve
 
Posts: 2
Joined: Mon Apr 30, 2007 9:11 pm

Postby Derek » Tue May 01, 2007 4:16 pm

Yes, this problem occurs because audio CD's are composed of 588 sample frames. Ideally, each track should start and end at a zero crossing of the waveform. However, in gapless mode, the program places boundaries at an exact multiple of 588 samples. This makes the music play seamlessly over the junction but it means that the transition is not necessarily at a zero crossing. Hence the potential for a click at the start of a track.

If you make all the transitions in the middle of quiet sections, then you should avoid this problem. Another way around the problem would be to put a "mini-fade" at the start and end of each track. This would almost certainly be subliminal when playing over a junction and it would completely eliminate these clicks.

To activate the "mini fade", process your live recording normally in Wave Corrector using the Gapless setting; but before you Save & Close, uncheck 'Gapless' on the Tracks menu. This will place all the boundaries as they would be for gapless, but it adds a very short fade to each boundary to ensure the zero crossing.

If you think this is a useful feature, I can include it more explicitly in a future release.
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom

Postby Steve » Fri Sep 07, 2007 9:39 am

I have been doing as you advised but have been tearing my hair out as I still get the problem, but I have had a revelation which I'll come to later. I still just don't understand why I have have achieved almost perfect results occasionally before I raised this issue on the forum though, unless of course it was just sheer luck. But luck with every track? Pretty high odds I would have thought!

Are you sure I should process the file in gapless mode and then when I'm finished uncheck gapless before saving? I don't fully understand what's going on, but the term"gapless" implies to me the opposite; that I should process the file and split into tracks in normal mode - which is easier anyway - and check gapless just before saving. Admittedly this doesn't eliminate the problem either, but it seems more logical to me, especially as track spliiting in normal mode is easier than in gapless mode.

Could I also ask whether cutting and splicing or other processing at the wrong time could contribute to this problem? I've been joining individual tracks into one file and eliminating the very short gap between tracks by cutting and splicing and then quite often splitting into tracks on the splice points, all in the same session. It occurs to me that track splits already done by this method might be upset by tracks splits further down the file.

To come to the revelation, I have found that there are no clicks when the CDs are played in players other than my ARCAM 7SE. I've only just discovered this because I've never owned a car with a CD player until very recently, but I haven't tried the CDs on another hi-fi setup. Is the ARCAM just too clever or maybe faulty, or is there someting else going on?

Thanks.
Steve
 
Posts: 2
Joined: Mon Apr 30, 2007 9:11 pm

Postby Glenn » Fri Sep 07, 2007 10:47 pm

Hi Steve,
You mentioned
I have found that there are no clicks when the CDs are played in players other than my ARCAM 7SE.

It does depend on the player. My Mission DAD5 plays seamlessly, yet the player in my car causes a slight gap, but without the clicks.
Are you recording from vinyl? Warps in the record produce a fluctuating dc condition which may cause problems. The coupling capacitors in the analogue output stage of the cd player see this as a low frequency and will 'ramp-up' to reproduce it. Have you tried using the rumble filter to remove the warp signal?
Glenn
Glenn
 
Posts: 212
Joined: Mon Feb 28, 2005 3:07 am
Location: Toronto, Canada

Postby Derek » Sun Sep 09, 2007 11:57 am

Hello

Yes, Glenn's suggestion is a very good one. I hadn't considered this, but if there is a DC offset on your recordings or significant rumble, then it could cause a click at the start and end of a track, even with the 'mini-fade', although the mini-fade should definitely reduce the severity of the click. I would strongly recommend trying Glenn's suggestion of using the rumble filter and seeing if it affects the problem.

If you want to play seamlessly over track boundaries then yes, you should be using gapless mode. I appreciate it is a little difficult to understand this. It's also difficult to explain but I'll give it a try!

The term 'gapless' really refers to the mode of CD burning. Normally, CD burning software puts 2 seconds of silence at the start of each track. (This is to conform to the red book standard for audio CD's). However, if you want tracks to play seamlessly from one track to the next then you have to burn the CD is gapless mode (also called 'disk-at-once).

This affects how you prepare your tacks for transfer. in the first case you need to trim the silence from the start and end of tracks to avoid having too long a gap after transfer to CD. In the latter case however, you must ensure that the tracks are not trimmed. Otherwise there would be a discontinuity at the track junctions. In Wave Corrector, when you set gapless mode, it prevents you from trimming the tracks or adding fades and/or silence. This ensures the seamless transition.

When in normal (non-gapless) mode, Wave Corrector puts a fade at the start and end of each track. This is precisely to avoid the possibility of a click. You can set the length of the fade but even when you set this to zero, the program still adds a very short fade of about 40 msec (what I've called a mini-fade). This was why I suggested you split your tracks in gapless mode and then uncheck gapless before saving. This would add the mini-fade and should eliminate the click while at the same time being subliminal when playing over a track boundary.

The fact that this isn't working successfully for you suggests there must be something else going on that I hadn't considered. It may be DC offset/rumble problem that Glenn alluded to. It may also be to do with your splices at track junctions. Although you should be able to do this without problem, it's possible that an unknown bug is asserting itself. I'll look into this and let you know if I discover anything. It would be helpful if you could do some experimenting to confirm whether or not the splices are causing the problem.
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom


Return to Support

Who is online

Users browsing this forum: No registered users and 3 guests

cron