Trying to load .ape files hangs program

Please post your support queries here.

Moderator: Derek

Trying to load .ape files hangs program

Postby Russell Crass » Sat Jan 22, 2005 11:55 pm

If I try to load an ape file, the program hangs and I get various windows errors.

One being "This program can not be closed. If it is being debugged, please resume it or close the debugger first."

This happens if I try to close the program after it hangs trying to load an ".ape" file.

The other error is "Incorrect wave file format. Only 16 bit stereo/44.1khz or 48khz sampling rate supported"

These "ape" files play just fine in winamp and can be decompressed back to waves just fine with Monkey's Audio v3.99. The "Insane" compression level was used to compress them.

Running Wave corrector v 3.1r1. Win2000Pro, P4, 1.8Ghz.

Any suggestions?

Russ Crass
Russell Crass
 
Posts: 1
Joined: Sun Jan 09, 2005 4:18 pm

Postby Derek » Sun Jan 23, 2005 10:12 am

Thanks for bringing this to my attention.

I'm fairly sure that the problem arises because the ape implementation in Wave Corrector is based on ape version 3.97. Version 3.99 that you are using for compression appears to use a slightly different data format. I've just made some experiments myself and although I did not get the same error messages as you, I can confirm that Wave Corrector will not open ape files created with MACv3.99

I'll endeavour to fix this in the next release.
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom


Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron