Page 1 of 1

Missing 'save' prompt

PostPosted: Thu May 26, 2011 8:51 pm
by bmbguy
I think I've found a scenario where I should have gotten a file 'save' prompt, but did not...

If I open a session file, start playback, and add a few cue markers, then stop playback and attempt to close the program ('X' in top right corner), I'll get a 'file save' prompt (as expected) because there are unsaved changes.

But if I... 1) open that same session file, 2) start playback, 3) add cue markers during play, 5) stop playback, then do 5) a manual 'save session'. Then I 6) resume playback and 7) add more cue markers during play, then 8) stop playback and 9) attempt to close the program ('X' in right corner again), the program will exit without the 'save' prompt even though I have added additional cue markers since the manual save in step 5, and the cue markers added in step 7 are lost.

I was working on a single song file, and did this by almost by accident when I was interrupted. Have tested scenario multiple times -- always works the same way. If I add a correction after the manual 'save session', instead of a cue marker, then I get the 'save' prompt as expected.

Guess I need to be diligent about doing my manual saves!! I'm using version 3.6r2 -- I'm up to date, aren't I?

PostPosted: Sat May 28, 2011 6:59 am
by Derek
Hello

Yes, that does seem like a bug. Thanks for reporting it and I confirm that I can reproduce the problem.

I'll fix it in the next release that I'm now starting to work on.

PostPosted: Sat May 28, 2011 2:54 pm
by bmbguy
Derek,

Thanks for confirming -- I just thought I'd mention it when I ran across it.

That said, it's a pretty minor issue that doesn't keep Wave Corrector from being an extremely useful tool. The software is pretty nice to have around -- many thanks to you for making it available.

Randy

PostPosted: Fri Jun 03, 2011 8:48 pm
by bmbguy
Derek,

Just FYI -- same issue occurs if I delete a correction after a manual save, then close the program. No 'save' prompt is generated.

Randy

PostPosted: Sat Jun 04, 2011 12:26 am
by Glenn
I've never noticed this issue myself, though problems have occurred because I didn't have autosave checked.

Wave Corrector is one of the most stable programs I've used, but the occassional hang up does inevitably come up. For the amount of work these sessions can represent I wouldn't dream of using WC without autosave.

PostPosted: Sat Jun 04, 2011 12:05 pm
by Derek
bmbguy wrote:Derek,

Just FYI -- same issue occurs if I delete a correction after a manual save, then close the program. No 'save' prompt is generated.

Randy


Thanks Randy. Yes, I've now fixed this as well. You'll see it in the next release.