Page 1 of 1

3.6 b0 Corrections List error

PostPosted: Sun Jul 26, 2009 1:16 am
by bmbguy
First thing I did with 3.6 b0 was to try to restore a previous session (saved with previous release, 3.5 rev2), and the correction list displays nothing but times of "00:00:000", and magnitude "16", and if I scroll up in the list, it looks like the top of the list is blank (white). Similar results with other previous session files, except one of them had "24"s in the magnitude field instead of the "16".

Then again, maybe I'm wrong in assuming that 3.6 should read the previous version's session files correctly...

PostPosted: Sun Jul 26, 2009 7:03 am
by Derek
Hello

Thanks for this report.

Yes the new version should open old session files.

I became aware of this problem just as I was uploading beta0 to the server. I thought I had fixed it but I now see that I hadn't. I've therefore pulled beta0 form the server. I'll upload a corrected version as soon as possible.

Thanks again

PostPosted: Sun Jul 26, 2009 7:48 am
by Derek
I've now uploaded the corrected version.

The problem appears to have been in Visual Studio. The debug version of the program was working OK but when I built the release version, I only did a few rudimentary checks. I've now done a clean re-build of the release version and the problem has dissappeared.

You can download the corrected version here http://www.wavecor.co.uk/wc36beta0.zip or from the beta download page. I've changed the zip file name slightly to avoid caching problems.

Thanks again for bringing this to my attention.

best regards

PostPosted: Sun Jul 26, 2009 5:48 pm
by bmbguy
Looks like the rebuild fixed it up.

Thanks! Now we can play around with it a bit...