3.6 b0 Corrections List error

Use this forum to post comments or suggestions about the current beta

Moderator: Derek

3.6 b0 Corrections List error

Postby bmbguy » Sun Jul 26, 2009 1:16 am

First thing I did with 3.6 b0 was to try to restore a previous session (saved with previous release, 3.5 rev2), and the correction list displays nothing but times of "00:00:000", and magnitude "16", and if I scroll up in the list, it looks like the top of the list is blank (white). Similar results with other previous session files, except one of them had "24"s in the magnitude field instead of the "16".

Then again, maybe I'm wrong in assuming that 3.6 should read the previous version's session files correctly...
Last edited by bmbguy on Sun Jul 26, 2009 2:09 pm, edited 1 time in total.
bmbguy
 
Posts: 40
Joined: Mon Jul 20, 2009 4:06 pm
Location: Central Texas, USA

Postby Derek » Sun Jul 26, 2009 7:03 am

Hello

Thanks for this report.

Yes the new version should open old session files.

I became aware of this problem just as I was uploading beta0 to the server. I thought I had fixed it but I now see that I hadn't. I've therefore pulled beta0 form the server. I'll upload a corrected version as soon as possible.

Thanks again
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom

Postby Derek » Sun Jul 26, 2009 7:48 am

I've now uploaded the corrected version.

The problem appears to have been in Visual Studio. The debug version of the program was working OK but when I built the release version, I only did a few rudimentary checks. I've now done a clean re-build of the release version and the problem has dissappeared.

You can download the corrected version here http://www.wavecor.co.uk/wc36beta0.zip or from the beta download page. I've changed the zip file name slightly to avoid caching problems.

Thanks again for bringing this to my attention.

best regards
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom

Postby bmbguy » Sun Jul 26, 2009 5:48 pm

Looks like the rebuild fixed it up.

Thanks! Now we can play around with it a bit...
bmbguy
 
Posts: 40
Joined: Mon Jul 20, 2009 4:06 pm
Location: Central Texas, USA


Return to Beta Comments

Who is online

Users browsing this forum: No registered users and 0 guests

cron