Programme crash on saving volume corrected files

Use this forum to post comments or suggestions about the current beta

Moderator: Derek

Programme crash on saving volume corrected files

Postby Glenn » Sun Sep 18, 2011 6:16 pm

Hi Derek, I'm trying to undo a volume correction saved to a session but the beta won't let me output the result...it crashes instead. I tried saving the session first (successfully) but it still won't output new files.*

While I'm here, I've noticed the click correction behaviour seems to have changed. Grouped corrections seem to interfere with each other, forcing me to go back and forth, sometimes having to remove them altogether to start over. I don't recall having this much difficulty before. Has there been any change to the way WC handles corrections?

Glenn

* Interstingly, 3.6 won't do it either. Help!

update: I was able to output the files, but with the window maximized. Previously it was in a smaller window....the save dialogue wouldn't even come up before the programme crash.

I have noticed some other display anomalies...spectrogram not coinciding with the track vue when making adjustments, track overview not updating with new track breaks, etc. I think these were all within a smaller window. I don't know...maybe it's just chasing rabbits.....
Black is beautiful!
Glenn
 
Posts: 212
Joined: Mon Feb 28, 2005 3:07 am
Location: Toronto, Canada

Postby Derek » Sun Sep 18, 2011 8:23 pm

Hi Glenn

I'll investigate and get back to you.

Note, if you load a v3.7 session file into v3.6, this does cause the program to crash on Save. Someone else has reported that. But this doesn't explain the first part of your report though.

Reference the grouped corrections interfering, there isn't any change to click correction in v3.7 so I think this is probably just coincidence. Perhaps, you could try the same file inv3.6 and v3.7 and verify that he click corrections are the same in each.

Thanks for the report.
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom

Postby Derek » Mon Sep 19, 2011 6:54 am

Hi Glenn

I can't seem to reproduce this problem. In v3.7, I can normalise/channel balance; save session file; restore session file; undo volume changes; and save files: all without a crash.

Are you sure you weren't using v3.6, having saved the session file in v3.7? This would cause the problem you reported.
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom

Postby Glenn » Mon Sep 19, 2011 3:49 pm

Quite certain. I made three unsuccessful attempts with the beta before trying with 3.6. The only time it worked was when the window was maximized.

Strange indeed.
Black is beautiful!
Glenn
 
Posts: 212
Joined: Mon Feb 28, 2005 3:07 am
Location: Toronto, Canada

Postby Derek » Wed Sep 21, 2011 7:58 am

Hi Glenn

I'm still having a problem reproducing this. I suspect the problem occurred because of something else you did rather than undoing the volume changes. Are you able to get the problem to recur? Or was it just a one off?

all the best
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom

Postby Glenn » Wed Sep 21, 2011 12:27 pm

I tried it twice with the beta before trying it again in 3.6. In all cases the error report came up instead of the save dialogue. I was able to save the files on the 4th attempt after maximizing the window. I did save the session changes before my second attempt but this did not help. Would it have been possible to save a 3.7 session in 3.6 or vice-versa? All I know is I keep the beta on the desktop so I had to go out of my way to try it with 3.6.

I've seen other programs with error reporting logs; maybe it's not a bad idea to bundle one with the betas as I can't be any more help in this matter.

I'll let you know if I experience anything else unusual.

Regards,
Glenn
Black is beautiful!
Glenn
 
Posts: 212
Joined: Mon Feb 28, 2005 3:07 am
Location: Toronto, Canada

Postby Derek » Wed Sep 21, 2011 1:30 pm

Hi Glenn

I can't help feeling that though it worked after maximising the window, this was pure coincidence. It's difficult to imagine how maximising the window would affect this but, of course, it's always possible.

Regarding the 3.6/3.7 session files, 3.7 can read a 3.6 session file but it will always write a 3.7 session file. If you try to load a 3.7 session file into 3.6, it will appear to load successfully, but you will not be able to save files, much as you described.

The problem another user had was they created a 3.7 session file and loaded it back in by double clicking on its icon. This caused Windows to use v3.6 as this is the version that's registered to the operating system.

thanks again
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom

Postby Glenn » Wed Sep 21, 2011 9:17 pm

You're probably correct, then. There were two files I wanted to undo which were in the same subdirectory, so it's likely that I did use explorer to open the session.

Sorry for the confusion on my part.

Glenn
Black is beautiful!
Glenn
 
Posts: 212
Joined: Mon Feb 28, 2005 3:07 am
Location: Toronto, Canada

Postby Derek » Thu Sep 22, 2011 9:03 am

It wasn't your fault at all. I should have realised this might be a problem and warned users.

With previous changes to the session file structure, the problem hadn't occurred because new version session files would have caused problems as soon as they were loaded.

With this latest change, that was very minor (adding the fade type to track boundaries), the new session file appears to load successfully in the old version; and it's only when you come to save that a problem arises.
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom


Return to Beta Comments

Who is online

Users browsing this forum: No registered users and 0 guests

cron