Set Volume button with Audiophile 2496

Use this forum to post comments or suggestions about the current beta

Moderator: Derek

Set Volume button with Audiophile 2496

Postby deadpoirotsketch » Thu Sep 08, 2005 4:56 am

This is a problem I have confirmed is still present in the 3.2beta. It is not difficult to work around and it is probably not Wave Corrector's "fault" but is due to the non-standard operation of the M-Audio Control Panel. I have used other software which has had similar problems.

I'm using XP and SP1 with 2496 driver 5.10.00.0029 and control panel version 1.03.16-2.1.04 downloaded from the M-Audio site.

In Wave Corrector's record dialog the Set Volume button has no effect.
There is no error message or negative effect.

I am able to adjust levels using either the H/W In 1/2 or the Master Volume sliders in the M-Audio Control panel and these are immediately reflected in the Wave Corrector "LEDs". So it isn't a big problem to get around, except perhaps if you are new to using audio on PCs.

My guess is that Wave Corrector tries to call up the Windows mixer when the Set Volume button is clicked, but as the Audiophile works outside of the Windows Mixer environment the call fails. Maybe this could be fixed by making it possible to edit which executable is called by the Set Volume button.

Personally I have always monitored and adjusted levels by manually invoking the M-audio control panel anyway, and if no-one else has commented then I expect everyone else has found it easy to work around.
deadpoirotsketch
 
Posts: 28
Joined: Sat Sep 03, 2005 7:59 pm
Location: UK

Postby Derek » Thu Sep 08, 2005 9:06 am

You can change the behaviour of the Set Volume button using the Devices... command on the File menu. This enables you choose a different executable.

As you say, by default, the Windows mixer applet is called up. But because the Audiophile does not support this, the button does nothing.

However, although you can pick a different executable, I haven't discovered which one to pick to launch the M_Audio Control Panel. If you do discover this, perhaps you could post it here.
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom

deltacpl.cpl

Postby deadpoirotsketch » Thu Sep 08, 2005 7:48 pm

Hi Derek,

It is a control panel applet, so has a cpl extension rather than the usual .exe or .com.

c:\windows\system32\deltacpl.cpl

I find it can be run from the Start|Run box, or with a right-click "Run As..." or even with just a double-click on the filename in Windows Explorer, just as if it were an .exe.

I have just tried changing the device for the Set Volume button to deltacpl.cpl, and then to the full c:\windows\system32\deltacpl.cpl and closing then restarting Wave Corrector and checking the change had been preserved. Unfortunately although the change was preserved, clicking Set Volume still didn't have any effect for me.

Using the info in the link at the foot of the article I tried setting the device text to

rundll32.exe shell32.exe,Control_RunDLL deltacpl.cpl

(Please note that the case, comma and spacing as above are essential.)
This actually works as expected from the Start Run box, but it doesn't work when the Set Volume button is clicked. As no error message is generated I can't take this much further because I don't know exactly what command Wave Corrector is attempting to execute - e.g. maybe WC already puts in a rundll32.exe before the contents of the device text box are placed on the command line.

This link may be of interest:
http://vlaurie.com/computers2/Articles/rundll32.htm
It explains how in XP rundll32.exe can be used to invoke control panel applets.

I hope this gives you enough info to take things further.
deadpoirotsketch
 
Posts: 28
Joined: Sat Sep 03, 2005 7:59 pm
Location: UK

control.exe

Postby deadpoirotsketch » Thu Sep 08, 2005 8:00 pm

An alternative approach, which also works from the Start|Run box in XP is to use control.exe

control.exe deltacpl.cpl

Unfortunately this doesn't work from the Set Volume button either.

More details of this method from:
http://support.microsoft.com/default.as ... -US;135068
deadpoirotsketch
 
Posts: 28
Joined: Sat Sep 03, 2005 7:59 pm
Location: UK

Postby citguy » Thu Sep 08, 2005 8:02 pm

I have the same problem with the M-Audio control panel. I can not affect the Wave Corrector recording volume so I use an external volume control.

Stan
citguy
 
Posts: 151
Joined: Sun Jan 09, 2005 4:32 pm
Location: Portland, Oregon USA

cracked it

Postby deadpoirotsketch » Thu Sep 08, 2005 9:15 pm

I had the idea that the cpl file might just call an exe file. Right or wrong I tracked down this file

c:\windows\system32\deltapnl.exe
It should have an associated deltapnl.dll in the same folder.

I plugged the filename (without the path) into the Record Volume Control textbox under File|Devices and then tried the Set Volume button - it worked! It didn't need the /r flag that the default entry for the Windows volume control is given.

The M-Audio control panel is a bit large and obscures the Wave Corrector record dialogue until it is moved to the side, but we have a step forward.

The M-Audio panel closes normally via the done button and reopens if the Set Volume button in Wave Corrector is clicked again.

I couldn't say if there are any other problems like memory leaks caused by running the M-Audio control panel this way - I'll use it and see if any unforseen problems arise.
deadpoirotsketch
 
Posts: 28
Joined: Sat Sep 03, 2005 7:59 pm
Location: UK

Postby Derek » Thu Sep 08, 2005 9:26 pm

Ah very interesting.

I think it should work if you insert a forward slash as below:

control.exe /deltacpl.cpl

Don't ask why it works. It's a secret :)
Derek Higgins
Wave Corrector Developer
http://www.wavecor.co.uk
Derek
Site Admin
 
Posts: 476
Joined: Sat Jan 01, 2005 7:57 pm
Location: Coleshill, United Kingdom

Postby citguy » Thu Sep 08, 2005 10:05 pm

Hi Derek. I plugged 'control.exe /deltacpl.cpl' into the device box in WC and can call up the M-Audio panel from WC but it still does not affect the recording level. It shows the input signal in M-Audio but the controls do not affect the WC levels. This is not a hugh problem for me because I have external vol control but it is irksome. (I know it is not a WC bug)
Stan
citguy
 
Posts: 151
Joined: Sun Jan 09, 2005 4:32 pm
Location: Portland, Oregon USA

audiophile control panel level control

Postby deadpoirotsketch » Thu Sep 08, 2005 10:42 pm

Hi Citiguy,

I can't ever alter the LED levels in HW In 1/2 but I can affect the level going from this input to the Master Volume by using either the sliders on HW In 1/2 or on Master Volume.

Depending on the cartridge I am using I usually leave the sliders on one of them 3-5db down to give me some headroom on the recorded wave, but as indicated elsewhere, I believe the reduced levels are reduced after the signals has been converted to the digital domain, so if the original signal is too hot you would still have clipping with the audiophile whatever the settings of these sliders.

In the Patch/Router tab I have Monitor mixer selected on the HW In 1/2 list. I can't test it right now but the sliders may have no effect unless you are routing via the monitor mixer in the Audiophile control panel. (I am going from memory because my Audiophile is not in my Internet PC).

I have only ever used the audiophile control panel called from outside Wave Corrector. I can't see why it should behave differently from inside Wave Corrector but I won't be able to try it until later tonight.
deadpoirotsketch
 
Posts: 28
Joined: Sat Sep 03, 2005 7:59 pm
Location: UK

Postby citguy » Thu Sep 08, 2005 11:00 pm

I can affect the M-audio meters with the sliders but it has NO affect on the Wave Corrector meters. It's probably a routing problem. On the other hand, M-audio does affect the sould output "from the card to my external amp". Curiouser and Curiouser.
Stan
citguy
 
Posts: 151
Joined: Sun Jan 09, 2005 4:32 pm
Location: Portland, Oregon USA

Postby deadpoirotsketch » Fri Sep 09, 2005 12:09 am

Hi Stan,

I've got deltapnl.exe as File|Devices|Record Volume Control.
I am recording at 44.1kHz and have called up the M-Audio Control Panel mixer with the Set Volume button in the WC Recording dialogue.

On the Monitor Mixer tab I have the three middle control sets muted and only Master Volume on the left and HW In 1/2 on the right unmuted. I have both "stereo linked", although that should not matter.

On the Patch/router tab I have the HW Out 1/2 setting checked for "Monitor mixer". All the other settings are greyed out for the Audiophile except the HW Out S/PDIF which is also set to Monitor mixer, but which I am not currently using.

On the M-Audio Control Panel HW settings tab there is a checkbox for "disable Audio app use of Monitor mixer and patchbay router - I have this UNchecked.

For me this setup definitely does affect the Wave Corrector LEDs as I move either the Monitor Mixer Master Volume sliders or the HW In 1/2 sliders.

Even if I check HW In 1/2 or Wav Out 1/2 in the Patch/Router tab under the HW Out 1/2 column I still am able to control the Wave Corrector LEDs using either active slider set - Master Volume or HW In 1/2 on the Monitor Mixer tab.

Moving the sliders also definitely affects the level of the recorded wav file.

If you have checked out your routing and it is as mine then I can only suggest a reboot and if that doesn't sort things out, check the drivers and control panel version you are using against the latest available from the M-Audio website.

I can't think of anything else that would be relevent to help you. If you still have problems then please give as much info about your settings as possible and I'll try to reproduce the problem. You wouldn't be using any other software like Virtual Audio Cable or Audio Repeater or Total Recorder that might complicate the situation?


I am using a licensed Wave Corrector 3.2beta downloaded about a month ago and Windows XP SP1.
deadpoirotsketch
 
Posts: 28
Joined: Sat Sep 03, 2005 7:59 pm
Location: UK

Postby citguy » Fri Sep 09, 2005 1:35 am

Thanks a bunch. I now have M-Audio control of WC recording functions. It was a routing problem, but I am not sure which setting did the trick. It was not the device/record volume control that did the trick but the "record device" setting that needed to be changed. My line out levels are not high enough that I need to control them with M-Audio but it is nice to have the ability if I need it.
Stan
citguy
 
Posts: 151
Joined: Sun Jan 09, 2005 4:32 pm
Location: Portland, Oregon USA

Postby deadpoirotsketch » Sat Sep 10, 2005 10:23 pm

In case anyone else follows this thread:

Summary: Setting up the Audiophile 2496 for Wave Corrector

If you only have one sound card then you may want to check your set up has the default device set to the Audiophile 2496.

Control Panel|Sounds And Audio Devices Properties|Audio Tab|Sound Recording|Default Device = M-Audio Delta AP Mon.Mixer

The Volume and Advanced buttons will be greyed out when you make this selection.

Set the Sound Playback Default Device on the same tab to "M-Audio Delta AP S/PDIF" if you are using the optical out and "M-Audio Delta AP Multichannel" if you are using the analogue outs from the Audiophile card.

You might also want to checkmark the "Use Default Devices only" checkbox.

Click the "Apply" button to accept the changes. The Volume "tab" in this control panel applet will display the name of your selected Output device.
If you have selected the M-Audio device as your default output device then the options in this tab will be greyed out.

Click the "OK" button to close the applet.

If you have more than one soundcard then I suggest that before a recording session with the Audiophile 2496, you check that you are actually using the devices you think you are using - some applications allow chosing devices that are not the defaults "on the fly" and you may have inadvertantly forgotten a change was made. Incidently, you are not required to use the audiophile 2496 as your output device even if you have selected it as your recording device.

Now invoke Wave Corrector. Open File|Devices. Set the recording and playback devices as you set the default devices in the Control Panel applet above.

(Wave Corrector should over-ride the Windows default devices while it is active, but if you have more soundcards installed and use other devices in other applications you may find multi-tasking makes things complicated, so that's why I suggest making the M-Audio card the Windows default as well as selecting it inside Wave Corrector).

In the Record Volume Control box you enter "deltapnl.exe" exactly as shown. Don't enter the quotes. (This file is placed in \windows\system32 with deltapnl.dll and deltacpl.cpl when you install the Audiophile 2496 drivers if you need to check. )

Click "OK" to accept the changes.

Now when you rcord in Wave Corrector and click the "Set Volume" button on the "Record File" dialogue the M-Audio Delta Control Panel will appear.

I suggest these settings:
Patchbay/router tab: Set both H/W Out 1/2 and HW Out S/PDIF to "Monitor Mixer". The defaults should be adequate on the other tabs.

When an input is supplied to the H/W Analogue In 1/2 port on the Audiophile card then on the Monitor Mixer tab you should see "LED" movement in both the H/W In 1/2 and Master Volume controllers. If not, check that you do not have these controllers muted - see checkboxes at the foot of each controller.

Adjusting the sliders by the side of either controller's LEDs will adjust the volume/amplitude of the signal on the LEDs displayed in the Wave Corrector Record File dialogue, and they will control the volume recorded.

These sliders will not affect the "volume" of the signal displayed in the H/W In 1/2 controller on the M-Audio Control Panel. If this signal is overloading (i.e. frequent displays of red in the LED bars at or approaching 0db) then you need to reduce the signal you are providing to the input of the Audiophile card. If recording from LP, this may mean using a phono pre-amp with variable output level. Those recording from a tapedeck are quite likely to find their tape deck has a control to vary the "line out" signal.

The Audiophile 2496 is a "cut-down" version of a series of soundcards for musicians with a need for multiple inputs and/or outputs to a computer. The Control Panel is used as a mixer in that case, but as the Audiophile has only one analogue and one optical input the mixing facilites are moot - hence so much is greyed out in the control panel. M-Audio supply the same control panel for most if not all their "Delta" series. Most professional equipment musicians might use to feed signals into a Delta card would have variable level line outputs - and this is possibly why the Audiophile card hasn't been equipped with a way of cutting a "hot" signal into its analogue inputs. (But I haven't contacted M-Audio to verify this as a certain fact).

I hope this helps someone. All errors are exclusively my responsibility.
deadpoirotsketch
 
Posts: 28
Joined: Sat Sep 03, 2005 7:59 pm
Location: UK

Postby citguy » Sat Sep 10, 2005 11:31 pm

All of your settings seem to work very well!!!! the Win 98 control panel will have a "multimedia" folder for the audio settings. Great job of writing a tutorial. The M-audio manual doesn't even come close.

Stan
citguy
 
Posts: 151
Joined: Sun Jan 09, 2005 4:32 pm
Location: Portland, Oregon USA

Postby Glenn » Sun Sep 11, 2005 3:34 am

The M-Audio Audiophile 2496 soundcard has no means of controlling analog levels by virtue of the paradigm for it's namesake: "Less is more".
Glenn
 
Posts: 212
Joined: Mon Feb 28, 2005 3:07 am
Location: Toronto, Canada

Next

Return to Beta Comments

Who is online

Users browsing this forum: No registered users and 0 guests

cron